GuangXingLiu

一蓑一笠一孤舟,一丈丝纶一鱼钩,一曲高歌一樽酒,一人独钓一江秋.

ADCD installation Q&A


***************************************************************************************************

Q:

A:

***************************************************************************************************

Q:

$  z1090instcheck

Checking zPDT prerequisites ....

 For more information about this script, issue : z1090instcheck  -?

 1. UBUNTU os level at 18.04 which is
         greater the minimum level                              OK
 2. UBUNTU kernel.shmmax of 18000000000 is greater than min.    *NOTE*
        shmmax should be greater than 1.1 times the sum
        of z memory (as specified in your devmap) for
        ALL your 1090 instances.
 3. UBUNTU (kernel.shmall * PAGE_SIZE) is 49152000000
        which is greater/equal to kernel.shmmax which is        OK
 4. UBUNTU kernel.msgmni is 512 which is                        OK
 5. UBUNTU kernel.msgmax is 65536 which is                      OK
 6. UBUNTU kernel.msgmnb is 65536 which is                      OK
 7. UBUNTU net.core.rmem_default is 1048576 which is            OK
 8. UBUNTU net.core.rmem_max is 1048576 which is                OK
 9. UBUNTU kernel.core_uses_pid is 1 which is                   OK
10. UBUNTU kernel.core_pattern is |/usr/share/apport/apport which is            BAD
11. UBUNTU ulimit -c is set to unlimited                                OK
12. UBUNTU ulimit -d is set to unlimited                        OK
13. UBUNTU pkg dmidecode is installed which is                  OK
14. UBUNTU pkg glibc 32bit is installed which is                OK
15. UBUNTU userid is 8 or less characters                       OK

A:

use:

/sbin/sysctl -p /etc/sysctl.conf


And then

# exit (leave root if you are in root)
$ cd /home/ibmsys1
$ sudo vim .bashrc
(Add the following lines beginning in column 1):
export PATH=/usr/z1090/bin:$PATH
export LD_LIBRARY_PATH=/usr/z1090/bin:$LD_LIBRARY_PATH
export MANPATH=/usr/z1090/man:$MANPATH
ulimit -c unlimited
ulimit -d unlimited
ulimit -m unlimited
ulimit -v unlimited



And check again:

$  z1090instcheck

Checking zPDT prerequisites ....

 For more information about this script, issue : z1090instcheck  -?

 1. UBUNTU os level at 18.04 which is
         greater the minimum level                              OK
 2. UBUNTU kernel.shmmax of 18000000000 is greater than min.    *NOTE*
        shmmax should be greater than 1.1 times the sum
        of z memory (as specified in your devmap) for
        ALL your 1090 instances.
 3. UBUNTU (kernel.shmall * PAGE_SIZE) is 49152000000
        which is greater/equal to kernel.shmmax which is        OK
 4. UBUNTU kernel.msgmni is 512 which is                        OK
 5. UBUNTU kernel.msgmax is 65536 which is                      OK
 6. UBUNTU kernel.msgmnb is 65536 which is                      OK
 7. UBUNTU net.core.rmem_default is 1048576 which is            OK
 8. UBUNTU net.core.rmem_max is 1048576 which is                OK
 9. UBUNTU kernel.core_uses_pid is 1 which is                   OK
10. UBUNTU kernel.core_pattern is core-%e-%p-%t which is                OK
11. UBUNTU ulimit -c is set to unlimited                                OK
12. UBUNTU ulimit -d is set to unlimited                        OK
13. UBUNTU pkg dmidecode is installed which is                  OK
14. UBUNTU pkg glibc 32bit is installed which is                OK
15. UBUNTU userid is 8 or less characters                       OK


Running uimcheck ...

The UIM client is configured in local mode.

UIMCHECK: serial number entry not yet added to local data base.
UIMCHECK: No local errors

$

***************************************************************************************************

Q: Ubuntu:

Error: required 32bit version of libstdc++ (lib32stdc++6) is not installed.

A:

sudo apt-get install lib32stdc++6

***************************************************************************************************

Q:

error while loading shared libraries: libawsDiskItf.so: cannot open shared object file: No such file or directory

A: The common cause for that message happens when you run Z1091_ADCD_install under root user id.

***************************************************************************************************

Q:

A:

***************************************************************************************************

Q:

A:

***************************************************************************************************

Q:

A:

***************************************************************************************************

Q:

A:

***************************************************************************************************

Q:

A:

***************************************************************************************************

Q:

A:

***************************************************************************************************

Q:

A:

***************************************************************************************************

Q:

A:

***************************************************************************************************






发表评论:

Powered By Z-BlogPHP 1.7.2